チャート操作

チャートは市場での価格変動を分析するために使用され、また、色々なテクニカル分析オブジェクトの構築にも利用できます。チャートは金融市場の分析に非常に有用な手段であるため、大きな関心がチャートに持たれています。チャート操作では以下のことができます。

  • チャートの種類
    通貨ペアチャートには次の3つの型があります。

    1. バーチャート : 一連のバーで表示したものです。
      このタイプのチャートを作成するには、「チャート」ツールバーMeta Trader tb charts bar chart チャート操作ボタン、Alt+1ホットキー「チャート設定」ウィンドウ(「チャート⇒プロパティ」)の「バーチャート」オプション、または、「チャート⇒バーチャート」メニューコマンドを実行します。

    2. ローソク足 : 一連のローソク足で表示したものです。
      このタイプのチャートを作成するには、「チャート」ツールバーMeta Trader tb charts candlestick チャート操作ボタン、 Alt+2ホットキー、または「チャート設定」ウィンドウの「ローソク足」オプション、または、「チャート⇒ローソク足」メニュー コマンドを実行します。

    3. ラインチャート : バーの終値を結んだ折れ線グラフです。
      このタイプのチャートを作成するには、「チャート」ツールバーMeta Trader tb charts line chart チャート操作ボタン、Alt+3ホットキー「チャート設定」ウィンドウのラインチャートオプション、または「チャート⇒ラインチャート」メニューコマンドを実行します。

  • チャートの保存
    クライアントターミナルでは、アクティブなチャートのヒストリーデータを、「CSV」、「PRN」または「HTM」の形式で保存することができます。
    上記のいずれかの形式でチャートを保存するには、「ファイル⇒名前を付けて保存」メニューコマンドを実行するか、Ctrl+Sホットキーを使用します。また、「BMP」または「GIF」の形式で画像として保存することもできます。それには「ファイル⇒画像として保存」メニューコマンドか、チャートのコンテキストメニューから「画像として保存」コマンドを実行します。

  • チャートの印刷
    アクティブなチャートをカラー印刷するには、チャート設定の「カラー印刷」のフラグを立て、「ファイル⇒印刷」メニューコマンドの実行、チャートのコンテキストメニューから「印刷」コマンドの実行、「標準」のツールバーMeta Trader tb standard print チャート操作ボタンのクリック、または、Ctrl+Pホットキーを使用します。「カラー印刷」が無効になっている場合、または使用できるカラープリンタがない場合、チャートは白黒で印刷されます。

  • 全画面表示
    「表示⇒チャート全画面表示」メニューコマンドの実行、または、F11キーを使用すると、チャートが全画面表示に切り替わります。画面上にはチャートウィンドウ、メインメニュー、及びチャートの切り替えバーのみが表示されます。元の表示に戻すには、同様に「表示⇒チャート全画面表示」メニューコマンドを使います。

  • MQL4プログラムの添付
    MQL4プログラムを実行するには、その前にチャートに添付する必要があります。それには「ナビゲータ」ウィンドウから使用するMQL4プログラムを選択してダブルクリックするか、「ナビゲータウィンドウ」コンテキストメニューの「チャートに表示」コマンドを実行します。また、MQL4プログラムをチャート上に「ドラッグ & ドロップ」しても同じ操作ができます。

  • 罫線分析ツールの操作
    罫線分析ツールとは、証券の価格、数量を数学的に処理したもので、将来の値動きを予想するために用います。テクニカル分析からのシグナルに基づいて、ポジションをいつオープンするかクローズするかを判断します。罫線分析ツールをチャートに取り込むには、「挿入⇒罫線分析ツール」メニューコマンドの実行、または「チャート」ツールバーMeta Trader tb charts indicators チャート操作ボタンをクリックし、サブメニューを開き、希望の罫線分析ツールを選択します。希望する罫線分析ツールを「ナビゲータ」ウィンドウから開いているチャートに「ドラッグ&ドロップ」しても同じことができます。チャートに取り込まれた罫線分析ツールの一覧は、「チャート⇒表示中の罫線分析ツール」メニューコマンド、チャートコンテキストメニューから「表示中の罫線分析ツール」コマンドの実行、またはCtrl+Iホットキーを使用して、「データウィンドウ」上で確認できます。

    テクニカル分析の操作に関する詳細は、「テクニカル分析の操作」セクションを参照してください。

  • オブジェクトの操作
    市場を分析するため、色々なグラ
    フィカルオブジェクトをチャートに取り込むことができます。それには「挿入」メニューコマンドか、「オブジェクト」ツールバーのボタンを使います。メニューにはオブジェクト、幾何学的図形、記号、テキストがグループ化されています。

    詳細は「グラフィカルオブジェクト」セクションを参照してください。

  • 周期の変更
    クライアントターミナルでは1分から1ヵ月間までの9つのデータ周期を選ぶことができます。テクニカル分析とオブジェクトを使って市場を分析するには、このように多種類の周期が必要となります。
    チャートで使用する周期を選ぶには、「周期設定」ツールバー「チャート」ツールバーMeta Trader tb charts period チャート操作ボタン、または「チャート⇒周期設定」メニュー、または、チャートの「周期設定」コンテキストメニューコマンドを実行します。

  • ズーム機能
    チャートは水平方向にズーム表示が可能です。これにより、画面に一度に表示されるバーの数を増減することができます。
    ズーム機能は「チャート」ツールバーMeta Trader tb charts zoom in チャート操作Meta Trader tb charts zoom out チャート操作 ボタン、「+」「-」キー、チャートのコンテキストメニューまたは「チャート」メニューの中の「ズームイン」/「ズームアウト」コマンドを使って操作します。
    チャートを垂直方向にズームアウト(縮小)するには、縦軸上の1点をマウスの左ボタンで押しながら下方向にドラッグします。縦軸上をダブルクリックするかキーパッドの「5」をクリックすると、元の大きさに戻ります。
    また、「チャート設定」ウィンドウの「スケールの固定」オプションを使って上部境界と下部境界を指定すると、正確な大きさにズームできます。同じく「チャート設定」ウィンドウの「スケールを1対1に固定」オプションを使うと、「1対1対応」の設定ができます。すなわち、縦軸の1pip(価格の最小単位)が横軸の1目盛りに対応するよう設定されます。

  • チャートのスクロール、自動スクロール、及びシフト
    スクロールとは、キーボードのカーソルキーの操作によって価格データをチャートの右/左へ移動することです。あるいは、F12キー(「ステップバイステップ」モードで棒足1本分左へ)またはShift+F12(棒足1本分右へ)でスクロールすることもできます。また、チャート上の任意の1点でマウスの左ボタン押しながらカーソルを右/左へ移動してもスクロールできます。「ファーストナビゲーションボックス」を使えば、日付と時間を指定して必要な領域だけを表示することもできます。価格データが表示されていない領域にチャートがスクロールされた場合は、表示されていないバーが自動的にダウンロードされます。

    チャートのスケールが固定されている場合は、垂直方向にもスクロールできます。それには、垂直方向のスケールのスライダーを押しながら、マウスを上下に移動します。チャートをデータが表示されていた元のレンジに戻すにはキーパッドの「5」を押すか、垂直方向のスケールの領域をダブルクリックします。

    自動スクロールは常に直近のバーの画面を表示します。このオプションが有効になっている場合は、チャートは自動的にその最終部分にスクロールされます。この機能は、「チャート」ツールバーMeta Trader tb charts auto scroll チャート操作ボタンをクリックするか、「チャート⇒自動スクロール」メニューコマンドで有効にすることができます。

    「チャートの右端移動」オプションは直近のバーを画面の右端からチャートのシフトマークにシフトします。チャートのシフトマーク(ウィンドウ上部にある灰色の三角形)は、マウスを使って、ウィンドウの大きさの10%~50%の範囲内で水平方向にシフトすることができます。チャートの右端移動は「チャート」ツールバーMeta Trader tb charts shift チャート操作ボタンをクリックするか、「チャート⇒チャートの右端移動」メニューコマンドで有効にできます。

  • チャートポジショニング
    通常、ウィンドウの左部分にチャートの基準点があります。特定時間のバーは、スクロールまたはファーストナビゲーションボックスを使って移動できる基準点に固定されています。周期が変わると、それまで使われていた周期の固定バーに対応する、新しい固定バーが計算されます。つまり、この基準点に最も近い周期がウィンドウの左側に表示されます。基準点(チャートの下部境界にある灰色の三角形)はマウスを使ってチャートウィンドウの範囲内で移動させることができます。基準点は「自動スクロール」オプションが無効の場合のみ表示されます。上記の機能は、ある一期間を異なる周期で分析するのに便利です。

    注意 : 「自動スクロール」オプションが有効になっている場合は、ポジショニング機能は作動しません。
  • 定型チャートの操作
    定型チャートとは、メモリーに保存されているチャートウィンドウのパラメータのことです。定型チャートには次のパラメータが保存されています。即ち、チャートの種類、データ周期、スケール、オブジェクトの全設定、テクニカル/カスタム分析、及びエキスパートアドバイザです。定型チャートにより複数のチャートの外見を素早く簡単に統一することができます。
    定型チャートを管理するメニューは「チャート⇒定型チャート」メニューコマンドの実行、チャートのコンテキストメニューから「定型チャート」コマンドの実行、または、「チャート」ツールバーMeta Trader tb charts template チャート操作ボタンをクリックして表示することができます。「保存」メニューコマンドは新規の定型チャートを保存し、「削除」メニューコマンドは既存の定型チャートを削除します。
    詳しくは「定型チャートとチャートグループ」セクションを参照してください。

  • チャートグループの操作
    チャートグループはチャート群の操作に便利な方法です。チャーのグループを開くと、各チャートとその全設定が、チャートグループが保存されたときと同じ場所に表示されます。
    チャートグループを管理するメニューは、「ファイル⇒チャートのグループ表示」メニューコマンドを実行するか、「標準」ツールバーMeta Trader tb standard profile チャート操作ボタン、または、現在のチャートグループ名を含むステータスバーをマウスでクリックすると開きます。
    詳しくは「定型チャートとチャートグループ」セクションを参照してください。

  • データの更新
    価格チャートにエラーまたは欠如が発生した場合は、データを更新する必要があります。価格データを更新するには、「チャート⇒更新」メニューコマンドか、チャートのコンテキストメニューから「更新」コマンドを実行します。これらのアクションが完了すると、欠けているバーがサーバから自動的にダウンロードされ、チャート上に表示されます。

マウスの使用

チャートは以下のようにマウスを使って直接操作することができます。

  • チャートウィンドウ上の1点を左クリックしたままカーソルを水平方向に移動すると、チャートをスクロールすることができます。

  • チャートの垂直方向のスケールを左クリックしたままカーソルを垂直方向に移動すると、チャートが垂直方向に拡大/縮小します。垂直方向のスケールをダブルクリックするとチャートが元の大きさに戻ります。

  • チャートの水平方向のスケール(ファーストナビゲーションボックスではない)を左クリックしたままカーソルを水平方向に移動すると、チャートが水平方向に拡大/縮小します。

  • チャートウィンドウ上で右クリックすると、チャートのコンテキストメニュー(下記で説明)が表示されます。

  • テクニカル分析の項目(ライン、記号、ヒストグラムバーなど)の上で左ボタンでダブルクリックすると、対応する罫線分析ツールの設定ウィンドウが表示されます。

  • テクニカル分析の要素を右クリックすると、テクニカル分析のコンテキストメニューが表示されます。

  • オブジェクト(ラインテキスト、または矢印)を、ターミナル設定に応じて左ボタンでシングルまたはダブルクリックすると、オブジェクトを選択できます。

  • 選択したラインを左クリックしたまま移動させると、そのラインが移動します。

  • Ctrlキーを押しながら選択したトレンドラインを左クリックしてそのまま移動させると、平行トレンドラインが引けます(チャネルを形成)。

  • チャートウィンドウ上でミドルボタンをクリックすると、カーソルが「十字」に変わります。

  • 選択したオブジェクトを右クリックすると、そのコンテキストメニューが開きます。

  • バーの終値、あるいはオブジェクトまたはテクニカル分析の要素にカーソルを合わせると、プロンプトが表示されます。

コンテキストメニューコマンドによるチャート操作

チャートのコンテキストメニューのコマンドには、チャート操作を目的としたものがいくつかあります。

  • エキスパートアドバイザエキスパートアドバイザを操作するサブメニューです。エキスパートアドバイザはMQL4で記述されたプログラムで、レートが更新されるたびに実行され、分析や取引を自動的に行うことができます。チャートに組み込まれたエキスパートを操作するコマンドもこのメニューにグループ化されています。このサブメニューを使って、エキスパートプロパティを変更、削除したり、プロパティのテストを開始したりできます。
    詳しくは「エキスパートアドバイザ」セクションを参照してください。

  • スクリプトを削除 : 実行可能なスクリプトを削除します。スクリプトとはMQL4で記述されたプログラムで、アクションを1回実行するためのものです。

  • 表示中の罫線分析ツール : チャートウィンドウに添付されたテクニカル分析を操作するウィンドウです。テクニカル分析とは、将来の通貨ペアの価格変動を予想するために、通貨ペアの価格及び/または数量を数学的処理のことです。テクニカル分析から受け取るシグナルに基づいて、ポジションをいつどのようにオープンするか、またはクローズするかを判断します。

  • オブジェクトリストグラフィカルオブジェクトを操作するウィンドウです。オブジェクトとは、ターミナル内にあり手動で取り込むオブジェクトのことで分析のために使用します。

  • 周期設定 : チャート周期を操作する管理するサブメニューです。
    チャート周期は「チャート」メニューまたは「周期設定」ツールバーコマンドでも操作できます。

  • 定型チャート定型チャートを操作するサブメニューです。 定型チャートとは、他のチャートにも使用できる一群のチャートウィンドウパラメータのことです。
    このサブメニューは「チャート」メニューの「定型チャート」コマンドでも呼び出されることができます。

  • 更新 : ヒストリーデータを更新します。このとき、利用可能なヒストリーデータの中で欠けているデータ及び新規データがすべてダウンロードされます。
    このアクションは「チャート」メニューの「更新」コマンドでも実行できます。

  • 自動調整 : すべてのテクニカル分析ウィンドウの高さをデフォルトとして設定します。
    このアクションはCtrl+Aホットキーでも実行できます。

  • グリッド : グリッドの表示/非表示を設定します。
    このアクションは「チャート」メニューの「グリッド」コマンドまたはCtrl+Gホットキーでも実行できます。

  • 出来高 : 出来高チャートの表示/非表示を設定します。
    このアクションは「チャート」メニューの「出来高」コマンドまたはCtrl+Lホットキーでも実行できます。

  • ズームイン : 1回の手順でチャートを水平方向にズームイン(拡大)します。
    チャートは「チャート」メニューの「ズームイン」コマンド、「+」キー、または、「チャート」ツールバーMeta Trader tb charts zoom in チャート操作ボタンでもズームインできます。

  • ズームアウト : 1回の手順でチャートをズームアウト(縮小)します。
    チャートは「チャート」メニューの「ズームアウト」コマンド、「-」キー、または、「チャート」ツールバーMeta Trader tb charts zoom out チャート操作ボタンでもズームアウトできます。

  • テクニカル分析ウィンドウの削除 : チャートからテクニカル分析ウィンドウを削除します。テクニカル分析のなかには特別なサブウィンドウに、独自の倍率で表示されるものもあります。このコマンドはそのようなサブウィンドウを削除します。
    テクニカル分析の操作に関する詳細は「テクニカル分析」セクションを参照してください。

  • 画像として保存 : チャートを画像として保存します(GIFまたはBMP形式)。
    このアクションは、「ファイル⇒画像として保存」メニューコマンドでも実行できます。

  • 印刷プレビュー : チャートの印刷イメージをプレビューします。
    このアクションは「ファイル⇒印刷プレビュー」メニューコマンド、「標準」ツールバーMeta Trader tb standard print prev チャート操作ボタンでも実行することもできます。

  • 印刷 : チャートを印刷します。プログラム設定で「カラー印刷」オプションにチェックが入っている場合は、カラーで印刷できます。
    このアクションは「ファイル⇒印刷」メニューコマンド、Ctrl+Pホットキー、または、「標準」ツールバーMeta Trader tb standard print チャート操作ボタンでも実行することもできます。

  • プロパティチャート設定ウィンドウを表示します
    このアクションはF8キーでも実行できます。

注意 : 「エキスパートアドバイザー」サブメニュー及び「スクリプトを削除」、「表示中の罫線分析ツール」、「オブジェクトリスト」の各コマンドは、対応するオブジェクトがチャートに取り込まれている場合にのみ有効となります。

チャート操作