Управление графиком

Графики позволяют анализировать динамику цен на рынке и используются для графического анализа, построения различных индикаторов и линейных инструментов. Графики являются исключительно ценным инструментом для анализа финансовых рынков, поэтому им уделяется большое внимание. Управление графиком — это:

  • Смена вида
    График финансового инструмента может быть трех видов:

    1. Бары — последовательность баров.
      Чтобы получить такой график, необходимо нажать кнопку Meta Trader tb charts bar chart Управление графиком панели “Графики”, комбинацию клавиш-акселераторов Alt + 1, соответствующую опцию окна свойств графика или выполнить команду меню “Графики — Бары”.

    2. Японские свечи — последовательность японских свечей.
      Для построения такого графика следует нажать кнопку Meta Trader tb charts candlestick Управление графиком панели “Графики”, комбинацию клавиш-акселераторов Alt + 2, соответствующую опцию окна свойств графика или выполнить команду меню “Графики — Японские свечи”.

    3. Линия — ломаная линия, соединяющая цены закрытия баров.
      Для получения этого графика необходимо нажать кнопку Meta Trader tb charts line chart Управление графиком панели “Графики”, комбинацию клавиш-акселераторов Alt + 3, соответствующую опцию окна свойства графика или выполнить команду меню “Графики — Линия”.

  • Сохранение
    Клиентский терминал позволяет сохранять исторические данные активного графика в виде текстового файла в форматах “CSV”, “PRN” и “HTM”.
    Чтобы сохранить их таким образом, нужно выполнить команду меню “Файл— Сохранить как” либо нажать на клавиши-акселераторы Ctrl + S. Кроме того, можно сохранять график в виде рисунка формата BMP или GIF. Для этого надо выполнить команду меню “Файл—Сохранить как рисунок”. Те же действия выполняются одноименной командой контекстного меню графика.

  • Печать
    Для цветной печати изображения активного графика нужно в настройках графика установить флажок “Цветная печать”, затем выполнить команду меню “Файл — Печать…”, одноименную команду контекстного меню графика, нажать на кнопку Meta Trader tb standard print Управление графиком панели инструментов “Стандартная” или на клавиши-акселераторов Ctrl+P. Если флажок “Цветная печать” снят или отсутствует цветной принтер, то график печатается в черно-белом виде.

  • Полный экран
    Выполнение команды меню “Вид — Полный экран” или нажатие на клавишу F11 приводит к переходу в полноэкранный режим. На экране, кроме окон графиков, остается главное меню и панель переключения графиков. Вернуться к исходному режиму можно, выполнив ту же команду.

  • Присоединение программ MQL4
    Перед началом выполнения программы MQL4 ее нужно присоединить к графику. Для этого нужно в окне “Навигатор” выбрать требуемую MQL4-программу и дважды щелкнуть на ней или выполнить команду контекстного меню “Присоединить к графику”. Также можно использовать технологию “Drag’n'Drop”.

  • Работа с индикаторами
    Индикатором называется математическое преобразование цены и/или объемов финансового инструмента для прогнозирования будущих изменений цен. На основе сигналов технических индикаторов принимаются решения относительно того, как и когда открывать или закрывать позицию. Индикаторы можно наложить на график при помощи команд меню “Вставка —Индикаторы” либо команд подменю управления индикаторами, которое открывается кнопкой Meta Trader  Управление графиком harts_indicators.gif" width="27" height="22" border="0" alt="Индикаторы"> панели инструментов “Графики”. Технология “Drag’n'Drop” также позволяет накладывать индикаторы из окна “Навигатор” на любое открытое окно. Список наложенных на график индикаторов можно просмотреть в “Окне Данных”, выполнив команду меню “Графики — Список индикаторов”, одноименную команду контекстного меню графика, либо нажав клавиши-акселераторы Ctrl+I.

    Более детальная информация о работе с техническими индикаторами приводится в одноименном разделе.

  • Работа с объектами
    Для проведения анализа на график можно также накладывать различные графические объекты. Для этого нужно воспользоваться командами меню “Вставка” либо кнопками панели инструментов “Графически инструменты”. В меню сгруппированы линейные инструменты, геометрические фигуры, значки и текст.

    Более детальная информация находится в разделе “Графические объекты”.

  • Смена периода
    Клиентский терминал поддерживает девять различных периодов данных, от минутных до месячных. Большое количество периодов графиков необходимо для проведения анализа рынков посредством технических индикаторов и линейных инструментов.
    Выбрать требуемый период графика можно при помощи панели “Период”, кнопки Meta Trader tb charts period Управление графиком панели “Графики”, меню “Графики — Период” либо выполнением одноименной команды контекстного меню графика.

  • Масштабирование
    Графики можно масштабировать по горизонтальной оси и тем самым увеличивать или уменьшать количество одновременно отображаемых на экране баров.
    Для этого предназначены кнопки Meta Trader tb charts zoom in Управление графиком / Meta Trader tb charts zoom out Управление графиком панели “Графики”, клавиши “+” / “-”, команды “Увеличение”/”Уменьшение” контекстного меню графика и меню “Графики”.
    Для уменьшения масштаба по вертикальной оси также можно захватить левой кнопкой мыши произвольную точку оси и сдвинуть ее вниз. Двойной щелчок мыши на вертикальной оси или нажатие клавиши “5″ на дополнительной цифровой клавиатуре восстанавливает масштаб.
    Кроме того, в окне свойств графика при помощи опции “Фиксировать масштаб” можно задать точный масштаб, определив верхнюю и нижнюю границы. Опция “Фиксировать масштаб 1:1″ того же окна позволяет установить масштаб “один к одному”, то есть, один пипс вертикальной оси будет соответствовать одному бару на горизонтальной.

  • Прокрутка, автопрокрутка и сдвиг графика
    Прокрутка — это смещение ценовых данных на графике вправо/влево, выполняемое курсорными клавишами клавиатуры. Кроме того, прокручивать график можно при помощи клавиш F12 (режим “Шаг за шагом” — смещение графика на один бар влево) и Shift+F12 (смещение графика на один бар вправо), а также при помощи мыши: удерживая левую кнопку мыши на любой точке графика, необходимо перемещать курсор вправо/влево. Также при помощи строки быстрой навигации можно отобразить необходимую область графика, указав конкретные дату и время. В случае сдвига графика в область, где отсутствуют ценовые данные, произойдет автоматическая загрузка недостающих баров.

    Если зафиксирован масштаб графика, его можно также прокручивать по вертикали. Для этого необходимо удерживая бегунок на вертикальной шкале перемещать мышь вверх/вниз. Чтобы вернуть график в пределы видимости, необходимо нажать клавишу “5″ на дополнительной цифровой клавиатуре либо дважды кликнуть мышью в области ценовой шкалы графика.

    Автопрокрутка предназначена для того, чтобы всегда перед глазами иметь последние бары. Если эта опция включена, с приходом новой котировки график автоматически перемещается в конец. Включить данную функцию можно кнопкой Meta Trader tb charts auto scroll Управление графиком рутка"> панели “Графики” и командой меню “Графики — Автопрокрутка”.

    Опция “Сдвиг графика” отодвигает последний бар от правого края экрана до метки сдвига графика. Метку сдвига графика (серый треугольник в верхней части окна) можно перемещать мышкой по горизонтали в пределах 10-50% размера окна. Сдвиг графика включается кнопкой Meta Trader tb charts shift Управление графиком панели “Графики” и командой меню “Графики — Сдвиг графика”.

  • Позиционирование графика
    Обычно точка привязки графика располагается в левой части окна. К ней привязывается бар с конкретным временем, который можно переместить при помощи прокрутки или строки быстрой навигации. При смене таймфрейма производится попытка рассчитать новый бар привязки, соответствующий бару на предыдущем периоде. То есть, с левого края окна графика будет отображаться ближайший к заданой точке временной промежуток. Точку привязки (серый треугольник на нижней границе графика) можно перемещать в пределах окна графика при помощи мыши. Он появляется только в случае, если отключена “Автопрокрутка”. Этот механизм удобен при анализе определенного временного промежутка на разных таймфреймах.

    Внимание: позиционирование не работает, если включена опция “Автопрокрутка”.
  • Работа с шаблонами
    Шаблоны представляют собой запись характеристик окна графика. В шаблоне сохраняются: вид графика, период, масштаб, все настройки линейных инструментов, технических и пользовательских индикаторов, а также экспертов. Шаблоны позволяют легко и быстро приводить множество различных графиков к единому виду.
    Меню управления шаблонами можно вызвать командой меню “Графики — Шаблон”, одноименной командой контекстного меню графика и кнопкой Meta Trader tb charts template Управление графиком панели “Графики”. Команда меню “Сохранить шаблон…” позволяет сохранить новый шаблон, а “Удалить шаблон” — удалить ранее созданный.
    Более детальная информация находится в разделе “Шаблоны и профили”.

  • Работа с профилями
    Концепция профилей предлагает удобный способ работы с группами графиков. Когда открывается профиль, каждый график со всеми настройками располагается точно в том же месте, где он был при сохранении профиля.
    Меню управления профилями можно открыть командой меню “Файл — Профили”, нажав кнопку Meta Trader tb standard profile Управление графиком панели инструментов “Стандартная” либо щелкнув мышью в окошке статусной строки с именем текущего профиля.
    Более детальная информация находится в разделе “Шаблоны и профили”.

  • Обновление данных
    К обновлению данных прибегают в случае возникновения ошибок или “дыр” на ценовом графике. Чтобы обновить ценовые данные, необходимо выполнить команду меню “Графики — Обновление” или одноименную команду контекстного меню графика. При выполнении всех этих действий происходит автоматическая загрузка с сервера недостающих баров и их прорисовка на графике.

Работа мышью

Управление графиком непосредственно мышью производится следующим образом:

  • нажатие левой кнопки мыши в любой точке окна графика и удержание с последующим горизонтальным перемещением курсора приводят к прокрутке графика;

  • нажатие левой кнопки мыши на вертикальной шкале графика и удержание с последующим вертикальным перемещением курсора приводят к изменению масштаба графика по вертикали, двойной щелчок мыши на вертикальной шкале восстанавливает масштаб;

  • нажатие левой кнопки мыши на горизонтальной шкале графика (кроме области строки быстрой навигации) и удержание с последующим горизонтальным перемещением курсора приводят к изменению масштаба графика;

  • нажатие правой кнопки мыши в любой точке окна графика вызывает контекстное меню графика (описано ниже);

  • двойной щелчок левой кнопки мыши на элементах технических индикаторов (линии, символы, стол

    Управление графиком